Fps issues



  • So lately my game does not want to go over 110 fps(I have it locked at 175, so that's not the issue) and whenever I get into fights it drops to 70 or even 50 fps. (I have everything set to low btw).
    I've tried changing some graphics settings in the config file, I've changed stuff in Nvidia Control Panel, I'm not running anything in the background, I even sent a ticket to Paladins support and they basically told me that nothing is wrong and I shouldn't use google while playing.
    My computer should also be good enough to run this game on the LOWEST settings at 1080p.(1060 6GB, I5-7400 3.0 GHz, 8GB Ram).
    Do you guys have any suggestions, maybe I'm missing something?



  • I had the same prob and finally managed to make it back at 170 fps lock.
    Here is what u need to do :
    ( this also can fix the sha lin fps drop when u shoot )

    1. uninstall the game with steam

    2. delete any high rez or paladins folder in program files

    3. download the game with the normal client (if u cant find it just ask me and ill give it to u)

    4. when playing paladins with normal client have steam closed

    5. go to nvidia control panel/manage 3Dsettings then in the right side go to global settings/ go all the way down to vertical sync and turn it off.

    6. go to geforce experience, and click on details on paladins game,and see if vertical sync is off ( if u dont have it u can manualy add it)
      7)turn battery boost off

    7. in paladins game settings make sure u have vertical sync off and borderless window not full screen

    8. this is only if u have a laptop and u are using a second monitor or u are using a pc with 2 monitors, on the monitor that is for gaming make sure that it is selected as main monitor.

    9. Sorry for bad english

    Hope this helps


  • PC

    @Time2KillSome1 said in Fps issues:

    • If you have a game pad plugged in unplug it.
    • Check for some process that's eating up cpu.
    • Make sure there isn't some pending windows update - things get wonky when it's waiting to update - mainly Win 10 has this issue.
    • Disable startup apps that you don't need. Ctrl Alt Del - the startup tab.


  • @inovatik I'll give it a try



  • my pc resources are at 30-35% when playing paladins.. still goes from 174 to 84.
    I have no controller or anything else plugged in, vsync off and use the game on medium.
    I don`t know what the hell is happening with this game.


Log in to reply