Problem with starting Paladins



  • @jhaglund it is already disabled and if I try to enable it it doesn't work the same. They advised me to do a clean boot of Windows but the same causes me that problem.

    I checked the version of Steam and it's the latest.


  • PC

    @U1324331193 Maybe post screen shots of DXDIAG - the system and display tabs. Be sure to mask any personal identifying info.



  • @U1324331193

    There's a few things you can try.

    (1):
    Download a fresh copy of your display drivers.
    Visit: https://downloadcenter.intel.com/product/96551/Intel-HD-Graphics-620

    Follow the steps:

    Note: Please download the latest display driver from the manufacturer website before uninstalling the current driver.

    a) Press Windows and X key together and click on Device Manager.

    b) Locate the display adapter and expand it.

    c) Right click on display driver icon and select Uninstall.

    d) Follow the onscreen instructions to uninstall the current version of the driver.

    e) Open the download folder which contains the setup file of the latest driver.

    f) Double click on the setup file and follow the onscreen instructions to reinstall the driver.

    Let us know how it goes.
    If (1) fails proceed to (2).

    (2): Run -> msconfig
    Under the General tab, select Load System Services.
    Go to the Services Tab and sort them by Manufacturer.
    Enable all Microsoft Corporations
    Enable EasyAntiCheat
    Leave the rest unchecked.
    Hit Apply and restart.

    Run Paladins. You will get a two dialogue windows about Steam Client Maintenance, click Cancel. Proceed

    Let us know how it goes.



  • Then I solved the problem by starting the game by typing "force-d3d9". I changed the settings of the DX11 by putting it off. Starting it normally works (without writing "force-d3d9"); so now I understand that the problem is the D3D11, do you know how I can fix it?



  • @jhaglund

    1. Previously I had tried to update the graphics card from the manufacturer's website with their application but in the installation of the update it gave me an error saying that the driver I had on the PC had particular changes and that it was not a generic driver.
    1. I tried but it gives me the same problem.
    1. When there is no "force -d3d9" code, the game starts only when the D3D11 is deactivated.


  • @U1324331193

    (1):
    Okay. Did you try to Uninstall the device driver?

    (2):
    Under Device Manager:
    What version /date does your display drivers say when you go to Properties -> Driver Tab

    (3):
    If you experience install problems:

    Use the ZIP files version of the drivers here: https://downloadmirror.intel.com/29465/a08/igfx_win10_100.7985.zip
    Extract them to a known location. (e.g., C:\igfx_win10_100.7985\Graphics)

    In your Driver Tab -> Update Driver -> Browse my computer for driver -> Let me pic from a list of available drivers on my computer -> Have disk -> browse to your extracted folder ->
    (e.g., C:\igfx_win10_100.7985\Graphics\ and Select -> iigd_dch.inf) -> Open -> Ok -> Select Intel 620 -> Next > let it install.
    Restart.
    Verify the version and date installed.

    (4):
    Reinstall DirectX
    Download DirectX Web Installer and reinstall DirectX.
    https://www.microsoft.com/en-us/download/confirmation.aspx?id=35

    (5):
    Browse to: C:\Windows\SysWOW64, and verify all your files are there.
    Browse to: C:\Windows\System32, and verify all your files are there.

    D3dx9_24.dll to 43
    D3dx10_33.dll to 43
    D3dx11_42.dll to 43
    D3d9.dll, d3d10.dll and d3d11.dll
    D3DCompiler_33.dll to 47
    D3d12.dll

    Let us know how it goes. Thanks.



  • @U1324331193 said in Problem with starting Paladins:

    When there is no "force -d3d9" code, the game starts only when the D3D11 is deactivated.

    What verson of DIrext X are you running.

    D3D11 enabled is forcing DX11
    With it disabled you are using what ever version is installed... I assume DX12

    You probably have some visual feature turned on that your video card cannot handle correctly.. When you force DX9 that feature is not supported at all so it runns as expexted.

    If it runs with DX11 disbales just usr it like that no reason to do anything further.



  • @Shadowpuppy In my pc there is the direct X 12.



  • @jhaglund

    1. Yes I have tried it now and I have it reinstalled from the pc itself.

    2. If you mean the display version is: 10.0.18362.693 on 21/06/2006.

    3. I have tried and I have an error that I am attaching to you through the image.

    4. I tried and told me that the latest version is present on the PC.

    5. I have searched all the files and they are present.

    Prova.PNG



  • @U1324331193

    The current Intel driver has a release date of 3/25/2020.

    Your picture doesn't appear to be under the Display adapters in Device Manager.
    Please try again, but go to Display adapter and repeat step (3) and select Intel 620.

    Show a picture of your device manager and expand your Display adapter.
    Also a picture of your Driver Tab of the Properties.

    Thanks



  • @jhaglund I managed to update the latest version that was in the package that you left me as a download and for now it's all right, I am attaching the tab of the devices.

    Prova #2.PNG

    Update: trying to start Paladins, it always crashes because D3D11 is active in the game settings. The fact is that directX is already up to date.


  • PC

    @U1324331193

    I hope you realize that system is not meant for gaming. Non gaming systems are generally meant for office work, movies and web browsing. You will likely have to use a lower resolution and detail settings and still be unhappy no matter which direct X version is being used.

    I don't want to discourage you but frankly don't get your hopes too high. Don't stop trying because of what I say - just telling you how it is.

    Is there a reason you're unwilling to use the force-d3d9 option that you said appears to work? DX11 probably won't help much with the performance and might even make it worse - depends on the system.

    To see if DX9 is really working good enough. Go into the shooting range and pick IO, use the ultimate. If it doesn't crash and you can see the ult then it will be down to playing with settings to get an acceptable frame rate.



  • @Vaporized I started Paladins with DX9 and with IO it's fine, even with the ultimate. (This obviously without that code)


  • PC

    @U1324331193

    Then just play with it like that. Leave DX11 disabled and forget about it.

    Just curious, what's the FPS (press F9 in a match) and is it stable during actual match play?



  • Yes. I thank everyone for the help you have given me. Thanks a lot.



  • @U1324331193

    Glad to see you got the driver updated.

    (1):
    Be sure you don't have any extra processes running. e.g., Skpe. Check your task manager and/ or go to your control panel and disable background apps, (Control Panel -> search Background Apps) switch them all off. Then Reboot.

    There's a few more things to try. Try game after a reboot between each step.

    (2):
    The Direct X Web Installer will install any 'missing' files
    Download DirectX End-User Runtime Web Installer from Official Microsoft Download Center

    https://www.microsoft.com/en-us/download/details.aspx?displaylang=en&id=35

    (3):
    The Dirext X redist (June 2010) installer will reinstall all Direct X files (except the couple of DX12 files),
    and replace any corrupt files in the process

    https://www.microsoft.com/en-us/download/details.aspx?id=8109

    (4):
    DirectX 11 Technology Update
    https://www.microsoft.com/en-us/download/details.aspx?id=1743

    (5): Try this DX installer:
    https://www.majorgeeks.com/files/details/dx_installer.html

    (6):
    You can browse your registry to:
    Run > Regedit
    Computer\HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\DirectX

    Double click the key: Version
    You'll see: 4.09.00.0904
    Change to: 4.08.00.0904
    Press Ok.

    Close and restart computer.

    You are running Windows 10, 64-bit?

    Thanks



  • @jhaglund I did everything, all right. Only point 5 does not go, says that the page does not exist.

    Yes, I use 64 bit Windows 10.



  • @U1324331193
    It should work. Works here.
    Download page:

    https://www.majorgeeks.com/mg/getmirror/dx_installer,1.html

    Still no luck?





  • When you get the "crash" report window, what does it report now?


Log in to reply